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CHAPTER-1 

1.1 Introduction 

Microsoft Excel 2013 is a spreadsheet program that is used to manage, analyze, and 

present data. It includes many powerful tools that can be used to organize and manipulate 

large amounts of data, perform complex calculations, create professional-looking charts, 

enhance the appearance of worksheets, and more. This handout provides an overview of 

the Excel 2013 user interface and covers how to perform basic tasks such as starting and 

exiting the program; creating, saving, opening, and closing workbooks; selecting cells; 

entering and editing data; formatting text and numbers; positioning cell contents; applying 

cell styles; and getting help. 

1.2 Use and Capability Of Excel 

1.2.1. Excel Formulas 
 Formulas & Functions are Excel!!! 
1.2.2. VBA, Macros & automation 

 VBA stands for Visual Basic for Applications, is a special language that Excel speaks. 

If you learn this language, you can make Excel do crazy things for you, like generate and 

email monthly reports automatically while you are busy reading this article. 

1.2.3. Pivot Tables 

 They save you a ton of time, let you create complex reports, charts & calculations all 

with few clicks. 

1.2.4. Lookup Formulas 

 lookup formulas (VLOOKUP, HLOOKUP, INDEX, MATCH etc.) are their favorite 

feature of Excel. Lookup formulas help you locate any information in your workbooks based 

on input criteria. By knowing how to write lookup formulas, you can build dashboards, make 

interactive charts, create effective models & feel pretty darn awesome. 

1.2.5. Excel Charts 

 Excel charts help you communicate insights & information with ease. By choosing 

your charts wisely and formatting them cleanly, you can convey a lot. 

1.2.6. Sorting & Filtering data 

 If Microsoft ever needs few extra billions of cash, they just have to turn sorting & 

filtering features in Excel to pay-per-use. These ad-hoc analysis features are so powerful & 

simple that any aspiring analyst must be fully aware of them. 

1.2.7. Conditional formatting 

 Conditional formatting is a hidden feature in Excel that can make your workbooks 

sexy. Just add some CF to highlight your data and you will turn boring into interesting. With 

new features like data bars, color scales & icon sets, conditional formatting is even more 

powerful. 

1.2.8. Drop down validation & form controls 

 Everyone loves to be in control. One can make your workbooks interactive, so that 

end users can control the inputs by using form controls & drop down lists of course. 

1.2.9. Excel Tables & Structural References 
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 Excel tables, a new feature added in Excel 2007 is a very powerful way to structure, 
maintain & use tabular data – the bread and butter of any data analysis situation. 
 
1.2.10. PowerPivot, Data Explorer & Data Analysis features 

1. Although Excel in itself is quite powerful, it struggles to analyze certain types of data, 

2. Combining multiple tables and creating reports from them 

3. Processing data from difference sources and getting output to Excel 

4. What if analysis, scenarios & optimization 
 

1.3 Starting Excel 

You can start Excel 2013 from the Start menu (in Windows 7) or by double-clicking 

an existing Excel file. When you start the program without opening a specific file, the Start 

screen appears, prompting you to open an existing workbook or create a new workbook. 

To start Excel 2013 from the Start menu: 

1.   Click the Start button, click All Programs, click Microsoft Office 2013, and then 
click Excel 2013. The Start screen appears (see Figure 1). 

2.   In the right pane, click Blank workbook. A new, blank workbook opens in the 
program window. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1 – Excel 2013 Start Screen 
 

1.4  Overview of the User Interface 
 

All the Microsoft Office 2013 programs share a common user interface so you can 
apply basic techniques that you learn in one program to other programs. The Excel 2013 
program window is easy to navigate and simple to use (see Figure 2 and Table 1). 
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Figure 2 – Excel 2013 Program Window 

 
Table 1 – Excel 2013 Program Window Elements 

 

Name Description 

Title bar Appears at the top of the program window and displays the name of the 
workbook and the program. The buttons on the right side of the Title bar 
are used to get help; change the display of the Ribbon; and minimize, 
restore, maximize, and close the program window. 

Quick Access 
toolbar 

Appears on the left side of the Title bar and contains frequently used 
commands that are independent of the tab displayed on the Ribbon. 

Ribbon Extends across the top of the program window, directly below the Title 
bar, and consists of a set of tabs, each of which contains groups of related 
commands. 

Formula bar Appears below the Ribbon and displays the data or formula stored in the 
active cell. It can also be used to enter or edit cell contents. 

Name box Appears on the left side of the Formula bar and displays the active cell 
address or the name of the selected cell, range, or object. 

Workbook 
window 

Appears below the Formula bar and displays a portion of the active 
worksheet. 

Sheet tab Each worksheet has a tab that appears below the workbook window and 
displays the name of the worksheet. 

Scroll bars Appear along the right side and bottom of the workbook window and 
enable you to scroll through the worksheet. 

Status bar Appears at the bottom of the program window and displays the status of 
Excel (such as Ready). The tools on the right side of the Status bar can 
be used to display the worksheet in a variety of views and to change the 
zoom level. 
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1.4.1 Ribbon 

The Ribbon is designed to help you quickly find the commands that you need to complete 

a task. 

It consists of a set of task-specific tabs (see Figure 3 and Table 2). The standard tabs are 

visible at all times. Other tabs, known as contextual tabs, appear only when you create or 

select certain types of objects (such as images or charts). A dialog box launcher  

appears in the lower-right corner of most groups on the Ribbon (see Figure 3). Clicking it 

opens a related dialog box or task pane that offers additional options or more precise 

control than the commands available on the Ribbon. 

You can collapse the Ribbon by clicking the Collapse the Ribbon button  on the right 

side of the Ribbon (see Figure 3) or by double-clicking the current tab. When the Ribbon is 

collapsed, only the tab names are visible. You can expand the Ribbon by double-clicking 

any tab. 

 
Figure 3 – Ribbon 

 
Table 2 – Ribbon Tabs 

 

Name Description 

File Displays the Backstage view which contains commands related to managing 
files and customizing the program. 

Home Contains the most frequently used commands. The Home tab is active  

by default. Insert Contains commands related to all the items that you can insert into a 
worksheet. 

Page Layout Contains commands that affect the overall appearance and layout of a 
worksheet. 

Formulas Contains commands used to insert formulas, define names, and audit 
formulas. 

Data Contains commands used to manage data and import or connect to external 
data. 

Review Contains commands used to check spelling, track changes, add 
comments, and protect worksheets. 

View Contains commands related to changing the view and other aspects of the 
display. 

1.4.2 Quick Access Toolbar 

The Quick Access toolbar provides one-click access to commonly used commands 

and options. 
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By default, it is located on the left side of the Title bar and displays the Save, Undo, 

and Redo buttons (see Figure 4). You can change the location of the Quick Access toolbar 

as well as customize it to include commands that you use frequently. 

 

Figure 4 – Quick Access Toolbar 

To add a command to the Quick Access toolbar: 

1.   On the Ribbon, right-click the command that 

 you want to add, and then click Add to Quick Access  

Toolbar on the shortcut menu. 

To remove a command from the Quick Access toolbar: 

1.   On the Quick Access toolbar, right-click the command  

that  you want to remove, and then click Remove from 

 Quick Access Toolbar on the shortcut menu. 

NOTE: Clicking the arrow on the right side 

of  the Quick Access toolbar displays a 

menu which includes additional commands 

and options that can be used to customize 

the toolbar. A check mark next to an item 

indicates that the item is selected (see Figure 

5). 

 

 

   
Figure 5 – Customize quick Access 
Toolbar Menu 

1.4.3 Mini Toolbar 

The Mini toolbar provides quick access 

to frequently used commands and appears 

whenever you right-click a cell or an object 

(see Figure 6). 

1.4.4 Shortcut Menus 

Excel 2013 includes many shortcut menus  

that appear when you right-click an item. 

Shortcut menus are context-sensitive, meaning 

they list commands that pertain only to the item 

that you right-clicked (see Figure 7). 

 

1.4.5 Backstage View 
 

The File tab (the first tab on the Ribbon) is used to display the Backstage view 

which contains all the commands related to managing files and customizing the 

program. It provides an easy way to create, open, save, print, share, export, and close 

files; view and update file properties; set permissions; set program options; and more. 

Figure 6 – Mini Tool Bar 

Figure 7 – Shortcut Menu 
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To display the Backstage view: 
1.   Click the File tab on the Ribbon (see Figure 8). 

 

 
 
 
To exit the Backstage View: 

Figure 8 – File Tab 

1.   Click the Back button in the upper-left corner of the Backstage view (see 
Figure 9). Or, press the Esc key. 

 

 
Figure 9 – Info Page of the Backstage View 

1.4.6 Formula Bar 

The Formula bar displays the contents of the active cell and can be used to enter or 

edit cell contents. The Formula bar contains three buttons (see Figure 10). The Insert 

Function button is always available, but the other two buttons are active only while you are 

entering or editing data in a cell. Clicking the Cancel button cancels the changes you make 

in the cell, which is the same as pressing the Esc key. Clicking the Enter button completes 

the changes you make in the cell, which is the same as pressing the Enter key. Clicking 

the Insert Function button opens a dialog box that helps you construct formulas. 

 
Figure 10 – Formula Bar 
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CHAPTER-2 
2.1 Overview of Workbooks 

An Excel file is called a workbook. Each new workbook contains one blank 

worksheet (see Figure 11). You can add additional worksheets or delete existing 

worksheets as needed. By default, a new workbook is named Book1 and the worksheet it 

contains is named Sheet1. Each worksheet consists of 1,048,576 rows (numbered 1 

through 1,048,576) and 16,384 columns (labeled A through XFD). The box formed by the 

intersection of a row and a column is called a cell. Cells are used to store data. Each cell is 

identified by its address which consists of its column letter and row number (e.g., cell A1 is 

the cell in the first column and first row). A group of cells is called a range. A range is 

identified by the addresses of the cells in the upper-left and lower-right corners of the 

selected block of cells, separated by a colon (e.g., A1:C10). Only one cell can be active at 

a time. The active cell has a green border around it and its address appears in the Name 

box on the left side of the Formula bar.  

 

Figure 11 – Worksheet 

2.2 Creating Workbooks 

When you start Excel 2013 and click Blank workbook on the Start screen, a new 

workbook opens in the program window, ready for you to enter your data. You can also 

create a new workbook while Excel 2013 is running. Each new workbook displays a default 

name (such as Book1, Book2, and so on) on the Title bar until you save it with a more 

meaningful name. 

To create a new workbook: 

1.   Click the File tab, and then click New. The New page of the Backstage view opens, 

displaying thumbnails of the available templates (see Figure 12). 

2.   In the right pane, click Blank workbook. A new, blank workbook opens in a new 

window Or You can also create a new workbook by pressing Ctrl+N. 
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Figure 12 – New Page of the Backstage View 

2.3 Saving Workbooks 

After creating a workbook, you can save it on your computer. Use the Save As command 

when you save a workbook for the first time or if you want to save a copy of a workbook in 

a different location, with a different file name, or in a different file format. Use the Save 

command to save changes to an existing workbook. 

NOTE: Excel 2013’s file format is called Excel Workbook and is the same as Excel 2007 

and 2010. This format has the .xlsx file extension and is not backward compatible with 

Excel versions prior to 2007. You can use Excel 2013 to save a workbook in the Excel 97-

2003 Workbook format with the .xls file extension to make it compatible with earlier 

versions of Excel, but you will not have access to all of Excel 2013’s features. 

To save a workbook for the first time: 

1. Click the File tab, and then click Save As. The Save As page of the Backstage 

view opens (see Figure 13). 

2.  Click Computer in the center pane, and then click the Browse button or a recent 

folder in the right pane. 
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 Click the File tab, and then click Save.  
 



 

 

On the Quick Access toolbar, click the Save button 

Press Ctrl+S. 

 

. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Figure 13 – Save As Page of the Backstage View 

 
3.   In the Save As dialog box, select a location to save the file, type a name in the File 

name box, and then click the Save button (see Figure 14). 

NOTE: By default, Excel 2013 workbooks are saved in the Excel Workbook format. To 

save a document in a different format, click the Save as type arrow and select the desired 

file format from the list. 

 
Figure 14 – Save As 

To save changes to a workbook: 

1.   Do one of the following: 
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2.4 Closing Workbooks 
 

When you finish working on a workbook, you can close it, but keep the program 
window open to work on more workbooks. If the workbook contains any unsaved 
changes, you will be prompted to save the changes before closing it. 

 
To close a workbook without exiting Excel: 

1.   Click the File tab, and then click Close. Or, press Ctrl+W. 
 

2.5 Opening Workbooks 
 

You can locate and open an existing workbook from the Start screen when Excel 
2013 starts or from the Open page of the Backstage view. The Start screen and the Open 
page also display a list of recently used workbooks which you can quickly open by clicking 
them. Each workbook opens in its own window, making it easier to work on two 
workbooks at once. 

 
To open a workbook: 

1.   Click the File tab, and then click Open. Or, press Ctrl+O. The Open page of the 

Backstage view opens, displaying a list of recently used workbooks in the right pane. 

2.   If the workbook you want is in the Recent Workbooks list, click its name to open it. 
Otherwise, proceed to step 3. 

3.   Click Computer in the center pane, and then click the Browse button or a recent folder 

in the right pane (see Figure 15). 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 15 – Open Page of the Backstage View 

 

4.   In the Open dialog box, locate and select the file that you want to open, and then click 

the Open button (see Figure 16). 
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Figure 16 – Open Dialog Box 

  

NOTE: When you open a workbook created with earlier versions of Excel in Excel 2013, 

the workbook opens in compatibility mode (indicated on the Title bar) with some of the new 

features of Excel 2013 disabled. You can easily convert the workbook to the Excel 2013 file 

format by clicking the Convert button on the Info page of the Backstage view (see Figure 17). 

 

 
Figure 17 – Convert Button on the Info Page of the Backstage View 
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CHAPTER-3 

Moving Around and Making Selections 

This section covers how to perform basic tasks such as moving around worksheets and 

selecting cells, rows, and columns. 

3.1 Moving Around Worksheets 

There are various ways to navigate through a worksheet. Using the mouse and the scroll 

bars, you can scroll through the worksheet in any direction. Using the navigational keys on 

the keyboard, you can move from cell to cell, move up or down one page at a time, or move 

to the first or last used cell in the worksheet (see Table 3). You can also navigate to a 

specific cell in the worksheet by entering its address in the Name box. 

NOTE: Scrolling with the mouse does not change the location of the active cell. To change 

the active cell, you must click a new cell after scrolling. 

Table 3 – Navigation Keyboard Shortcuts 

Key Action 

Down arrow or Enter Moves the active cell one cell down. 

Up arrow or Shift+Enter Moves the active cell one cell up. 

Right arrow or Tab Moves the active cell one cell to the right. 

Left arrow or Shift+Tab Moves the active cell one cell to the left. 

Page Down Moves the active cell down one page. 

Page Up Moves the active cell up one page. 

Alt+Page Down Moves the active cell right one page. 

Alt+Page Up Moves the active cell left one page. 

Ctrl+Home Moves the active cell to cell A1. 

Ctrl+End Moves the active cell to the last used cell in the worksheet. 
 
 
3.2 Selecting Cells, Rows, and Columns 

In order to work with a cell, you must first select it. When you want to work with more than 
one cell at a time, you can quickly select ranges, rows, columns, or the entire worksheet. 
3.2.1 To select a single cell: 
1.   Click the desired cell (see Figure 18). 
 

 
 
 
3.2.2 To select a range of  cells: 

 

1.   Click the first cell that you want to include in the range, hold down the Shift key, and 

then click the last cell in the range (see Figure 19). Or, drag from the first cell in the range to 

the last cell

Figure 18 – Active Cell 
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NOTE: When a range is selected, every cell in the range is highlighted, except for the 

active cell. You can deselect a range by pressing any arrow key or by clicking any cell in 

the worksheet. 

3.2.3 To select nonadjacent cells or ranges: 

1.   Select the first cell or range, hold down the Ctrl key, and then select the other cells or 

ranges (see Figure 20). 

        

Figure 19 – Selected Range                                         Figure 20 – Selected Nonadjacent Ranges 
 

3.2.4 To select a single row or column: 

1. Click the header of the row or column that you want to select (see Figure 21 and Figure22). 

NOTE: When a row or column is selected, every cell in the row or column is highlighted, 

except for the active cell. You can deselect a row or column by pressing any arrow key or 

by clicking any cell in the worksheet. 

 

 
Figure 21 – Selected Row                                                      Figure 22 – Selected Column 

 

3.2.5 To select multiple adjacent rows or columns: 

1.   Click the header of the first row or column that you want to select, hold down the Shift 

key, and then click the header of the last row or column. Or, drag across the headers of 

the rows or columns that you want to select. 

3.2.6 To select multiple nonadjacent rows or columns: 

1.   Hold down the Ctrl key, and then click the headers of the rows or columns that you 

want to select. 

3.2.7 To select all cells in a worksheet: 
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1.   Click the Select All button in the upper-left corner of the worksheet (see Figure 23). 

Or, press Ctrl+A. 

 

 
Figure 23 – Select All Button 

3.3 Editing Worksheets 

After creating a workbook, you can start adding data to a worksheet. If you need to make 

changes, you can easily edit the data to correct errors, update information, or remove 

information you no longer need. 

3.3.1 Entering Data 

You can add data by entering it directly in a cell or by using the Formula bar. A cell can 

contain a maximum of 32,767 characters and can hold any of three basic types of data: 

text, numbers, or formulas. 

NOTE: If you make a mistake while entering data, simply press the Backspace key to 

delete all or a portion of your entry and enter the correct data. 

3.3.1.1 Entering Text 

You can enter text in a worksheet to serve as labels for values, headings for columns, or 

instructions about the worksheet. Text is defined as any combination of letters and 

numbers. Text automatically aligns to the left in a cell. If you enter text that is longer than 

its column’s current width, the excess characters appear in the next cell to the right, as 

long as that cell is empty (see Figure 24). If the adjacent cell is not empty, the long text 

entry appears truncated (see Figure 25). The characters are not actually deleted and will 

appear if the width of the column is adjusted to accommodate the long text entry. 

 
 
 

Figure 24 – Overflowing Text Entry                                              Figure 25 – Truncated Text Entry 
 
 

To enter text: 

1.   Select the cell in which you 
want to enter text. 

2.   Type the desired text, and then 
press the Enter key. 

 
NOTE: To enter a line break in 
a cell, press Alt+Enter (see 

Figure 26). 

 
 
 
 
 
 
 
Figure 26 – Cell with Line Breaks 



Microsoft Excel    15 

 

 
3.3.1.2 Entering Numbers 

Numeric entries contain only numbers and are automatically aligned to the right in a cell. 

Numbers can exist as independent values, or they can be used in formulas to calculate 

other values. You can enter whole numbers (such as 5 or 1,000), decimals (such as 0.25 

or 5.15), negative numbers (such as -10 or -5.5), percentages (such as 20% or 1.5%), and 

currency values (such as $0.25 or $20.99). 

NOTE: A number that does not fit within a column is displayed as a series of pound signs 

(#####). To accommodate the number, increase the column width. 

To enter a number: 

1.   Select the cell in which you want to enter the number. 
2.   Type the desired number, and then press the Enter key. 
 

3.3.1.3 Entering Dates and Times 

Excel treats dates and times as special types of numeric values. 

To enter a date: 

1.   Select the cell in which you want to enter the date. 
2.   Type the month, day, and year, with each number separated by a forward slash (/) or a 
hyphen (-), and then press the Enter key. 
To enter a time: 

1.   Select the cell in which you want to enter the time. 

2.   Type the hour, a colon (:), and the minutes, press the Spacebar, type a for A.M. or p 

for P.M., and then press the Enter key. 

3.4 Editing Data 

If a cell contains a long entry and you only want to change a few characters, it is faster to 

edit the data than to retype the entire entry. You can edit the contents of a cell directly in 

the cell or by using the Formula bar. 

To edit data: 

1.   Double-click the cell that contains the data you want to edit. The cursor (a blinking 

vertical line) appears in the cell in the location that you double-clicked. 

2.   To insert characters, click where you want to make changes, and then type the new 

characters. 

NOTE: You can also move the cursor by pressing the Home, End, or arrow keys. 

3.   To delete characters, click where you want to make changes, and then press the 

Backspace or Delete key. 

NOTE: Pressing the Backspace key deletes the character to the left of the cursor; 

pressing the Delete key deletes the character to the right of the cursor. 

4.   When you are finished, press the Enter key. 

NOTE: If you are editing data and decide not to keep your edits, press the Esc key to 

return the cell to its previous state. 
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3.5 Replacing Data 

You can replace the entire contents of a cell with new data. Any formatting applied to the 

cell remains in place and is applied to the new data. 

To replace data: 

1.   Select the cell that contains the data you want to replace. 

2.   Type the new data, and then press the Enter key. 

 

3.6 Deleting Data 

You can delete the entire contents of a cell if the data is no longer needed. Deleting data 

does notremove any formatting applied to the cell. 

To delete data: 

1.   Select the cell that contains the data you want to delete, and then press the Delete 

key. 

3.7 Moving and Copying Cells 

When editing a worksheet, you may want to duplicate a cell in another location or remove 

(cut) a cell from its original location and place it in a new location. A copied cell can be 

pasted multiple times; a cut cell can be pasted only once. 

NOTE: Cut or copied data is stored on the Clipboard, a temporary storage area. You can 

access it by clicking the dialog box launcher      in the Clipboard group on the Home tab 

of the Ribbon (see Figure 27). 

To move or copy a cell: 

1. Select the cell that you want to move or copy.  

2. On the Home tab, in the Clipboard group, do one of the 

following:     To move the cell, click the Cut button   Or press Ctrl+X. 

 

 

3. 

   To copy the cell, click the Copy button   . Or, press Ctrl+C. 

Select the cell where you want to paste the cut or copied cell 

 

 

 

 

 

.  

 

4. 

On the Home tab, in the Clipboard group, click the Paste 

button  

. Or, press 

Ctrl+V. 

NOTE: When you cut or copy cells, a marquee (scrolling dotted line) appears around 
the cells. You can remove the marquee by pressing the Esc key (see Figure 28). 
 
 
 
 
 
 
 
 
 

Figure 27 – Clipboard Group on the Home Tab                                   
Figure 28 – Cells with Marquee
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3.8 Using Paste Special 

The Paste Special command is a very useful editing feature. It allows you to control which 

aspect of the copied cell to paste into the target cell. For example, you can choose to 

paste only the copied cell’s formula, only the result of the formula, only the cell’s 

formatting, etc. You must copy to use the Paste Special command; when you cut, the 

Paste Special command is not available. 

To use the Paste Special command: 
1.   Select the cell that contains the value, formula, or formatting you want to copy. 
2.   On the Home tab, in the Clipboard group, click the Copy button       . 
3.   Select the cell where you want to paste the value, formula, or formatting. 
4.   On the Home tab, in the Clipboard group, click the Paste arrow and select the desired 
option from the menu (see Figure 29). 
 

NOTE: Pointing to a command on the Paste menu displays its name in a ScreenTip. You 

can access more options by clicking Paste Special at the bottom of the menu. 

 

 
Figure 29 – Paste 

Menu 
 
3.8.1 Copying cell content with Special copy option 

Use the Paste Special dialog to copy complex items from a Microsoft Office Excel 
worksheet and paste them into the same worksheet or another Excel worksheet using only 
specific attributes of the copied data, or a mathematical operation that you want to apply to 
the copied data. 

Paste 

All       Pastes all cell contents and formatting of the copied data  

Formulas     Pastes only the formulas of the copied data as entered in the 
formula bar.   
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Formats  Pastes only cell formatting of the copied data. 

Values      Pastes only the values of the copied data as displayed in the 
cells. 

Comments      Pastes only comments attached to the copied cell. 

Validation     
 . 

Pastes data validation rules for the copied cells to the paste area 

All using Source 
Theme      

Pastes all cell contents in the document theme  formatting that is  
applied to the copied data. 

All except 
borders        

Pastes all cell contents and formatting applied to the  copied cell 
except borders. 

Column widths    
   

Pastes the width of one copied column or range of             
columns to another column or range of columns. 

Formulas and 
number formats     

Pastes only formulas and all number formatting options from the 
copied cells. 

Values and 
number formats     

Pastes only values and all number formatting options from the  
 copied cells 

Operation 

Specify which mathematical operation, if any, that you want to apply to the copied data. 

None Specifies that no mathematical operation will be applied to the 
copied data. 

Add Specifies that the copied data will be added to the data in the 
destination cell or range of cells. 

Subtract Specifies that the copied data will be subtracted from the data in 
the destination cell or range of cells. 

Multiply Specifies that the copied data will be multiplied with the data in 
the destination cell or range of cells. 

Divide Specifies that the copied data will be divided by the data in the 
destination cell or range of cells. 

Skip blanks Avoids replacing values in your paste area when blank cells occur 
in the copy area when you select this check box. 

Transpose Changes columns of copied data to rows, and vice versa when 
you select this check box. 

Paste Link     
(Linking Worksheet) 

Links the pasted data on the active worksheet to the copied data. 

 



Microsoft Excel    19 

 

 
 

3.9 Clearing Cells 
You can clear a cell to remove its contents, 
formats, or comments. When clearing a 
cell, you must specify whether to remove 
one, two, or all three of these elements 
from the cell. 
To clear a cell: 

1.   Select the cell that you want to clear. 
2.   On the Home tab, in the Editing 

group, click the Clear button and 

select the desired option from the 
menu   
                                                 Figure 30 – Clear Menu

 
 
3.10 Undoing and Redoing Changes 

Whenever you make a mistake, you can easily reverse it with the Undo command. After 

youhave undone one or more actions, the Redo command becomes available and allows 

you to restore the undone actions. 

To undo an action: 

1.   On the Quick Access toolbar, click the Undo button       . Or, press Ctrl+Z. 

To redo an action: 

1. In the Quick Access toolbar, click the Redo button       . Or, press Ctrl+Y. 
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CHAPTER-4 

Formatting Worksheets 

Excel 2013 includes a number of features that can be used to easily format a worksheet. 

Formatting enhances the appearance of a worksheet and makes it look professional. 

4.1 Formatting Cells and Cell Contents 

You can format cells and cell contents by changing the font, font size, font style, and font 

color, as well as adding cell borders and changing the background color of cells. Since 

formatting is attached to the cell and not to the entry, you can format a cell before or after 

you enter the data. The Font group on the Home tab of the Ribbon contains the most 

commonly used formatting commands (see Figure 31). You can also format cells using the 

Format Cells dialog box which  

can be opened by clicking the dialog box launcher       in the Font group. 

 
 
 
 
 
 
 
 
 
 

Figure 31 – Font Group on the 
Home Tab 

 
4.1.1 Changing the Font and Font Size 

A font defines the overall appearance or style of text lettering. Font size controls the height 

of the font. The default font in new Excel 2013 workbooks is Calibri; the default font size is 

11 points. 

To change the font: 

1.   Select the cell that you want to format. 

2.   On the Home tab, in the Font group, click the Font arrow and select the desired font 

from the list (see Figure 32). 

 

To change the font size: 

1.   Select the cell that you want to format. 

2.   On the Home tab, in the Font group, click the Font Size arrow and select the desired 

font size from the list (see Figure 33). If a font size you want is not listed in the Font Size 

list, click in the Font Size box, type the desired number, and then press the Enter key. 

NOTE: You can also change the font size by clicking the Increase Font Size butt on              

or  Decrease Font Size button         in the Font group on the Home tab of the Ribbon.  

Button.  
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Figure 32 – Font List 

Figure 33 – Font Size List

4.1.2 Changing the Font Color and Fill Color 

You can change the font color of cell contents or the background color of cells to 

emphasize important data or add visual impact to a worksheet. 

To change the font color: 

1.   Select the cell that you want to format. 

2.   On the Home tab, in the Font group, click the Font Color button to apply the most 

recently used color, or click the Font Color arrow and select a different color from the 

color palette (see Figure 34). 

To change the fill color: 

1.   Select the cell that you want to format. 

2.   On the Home tab, in the Font group, click the Fill Color button to apply the most 

recently used color, or click the Fill Color arrow and select a different color from the color 

palette (see Figure 35). 

 

NOTE: You can remove the fill color from a selected cell by clicking the Fill Color arrow, 

and then clicking No Fill on the palette. 

 

 
Figure 34 – Font Color Palette                                                   Figure 35 – Fill Color Palette 
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4.1.3 Applying Font Styles 

You can apply one or more font styles to emphasize important data in a worksheet. Font 

styles are attributes such as bold, italic, and underline. Bolding makes the characters 

darker. Italicizing slants the characters to the right. Underlining adds a line below the cell 

contents, not the cell itself. 

To bold or italicize data: 

1.   Select the cell that you want to format. 

2.   On the Home tab, in the Font group, click the Bold button   or Italic      

button       . 

 

To underline data: 

1.   Select the cell that you want to format. 

2.   On the Home tab, in the Font group, do one of the following (see Figure 36): 

 To apply a single underline, click the Underline button. 

 To apply a double underline, click the Underline arrow, and then click Double 

Underline on the menu. 

 

 
Figure 36 – Underline Menu 

 

NOTE: The Bold, Italic, and Underline buttons are toggles. If you select a cell to which 

one of these formats has been applied, and then click the corresponding button, that 

format is removed. 

 

4.1.4  Adding Cell Borders 
You can add borders to any or all sides of a 
single cell or range. Excel 2013 includes 
several predefined border styles that you 
can use. 
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To add cell borders: 

1.   Select the cell to which you 
want to add borders. 

2.   On the Home tab, in the Font 
group, click the Borders button to 

apply the most recently used 
border, or click the Borders 

arrow and select a different 
border from the menu (see Figure 
37). 

 
NOTE: You can remove all 
borders from a selected cell by 
clicking the Borders arrow, 
and then clicking No Border 

on the menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 37 – Borders Menu 
 
 
4.2  Formatting Numbers 

You can apply number formats to cells containing numbers to better reflect the type of data 

they represent. For example, you can display a numeric value as a percentage, currency, 

date or time, etc. The Number group on the Home tab of the Ribbon contains the most 

commonly used commands for formatting numbers (see Figure 38). You can also format 

numbers using the Number tab of the Format Cells dialog box which can be opened by 

clicking the dialog box  launcher       in the Number group. 

  NOTE: Formatting does not change the actual value stored in a cell. The actual value is 
used in calculations and is displayed in the Formula bar when the cell is selected. 

 
 
 
 
 
 
 

 
Figure 38 – Number Group on the Home Tab 
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To format numbers: 

1.   Select the cell that you want to 
format. 
2.   On the Home tab, in the 

Number group, do one of the 

following (see Figure 38): 
   Click the Accounting Number 

 
Format button        to display 
the number with a dollar sign, 
comma separators, and two 
decimal places. 

 
NOTE: You can select a 
different currency symbol by 
clicking the Accounting 
Number Format arrow and 
selecting the desired symbol 
from the menu. 

 
 Click the Percent Style button 

to convert the number to a 
percentage and display it with a 
percent sign and no decimal 
places. 

 
   Click the Comma Style button 

to display the number with 
comma separators and two 
decimal places. 

 
NOTE: You can access 
additional number formats by 
clicking the Number Format 
arrow and selecting the desired 
option from the menu (see 
Figure 39). 

 
Figure 39 – Number Format Menu 

 
To change the number of decimal places: 

1.   Select the cell that you want to format. 

2.   On the Home tab, in the Number group, do one of the following (see Figure 38): 

 Click the Increase Decimal button        to increase the number of decimal 

places. 

 Click the Decrease Decimal button        to decrease the number of decimal 

places. 
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4.3 Positioning Cell Contents 

You can change the alignment, indentation, and orientation of cell contents, wrap the 

contents within a cell, and merge cells. The Alignment group on the Home tab of the 

Ribbon contains the most commonly used commands for positioning cell contents (see 

Figure 40). You can also position cell contents using the Alignment tab of the Format Cells 

dialog box which can be opened by clicking the dialog box launcher       in the Alignment 

group. 

 

 

 
 

Figure 40 – Alignment Group on the Home Tab 
 

 

4.3.1 Aligning Data 

By default, Excel 2013 aligns numbers to the right and text to the left, and all cells use 

bottom alignment. The Alignment group on the Home tab of the Ribbon includes six 

alignment buttons that can be used to change the horizontal and vertical alignment of cell 

contents. 

    The Align Left button         aligns the cell contents with the left edge of the cell. 

    The Center button        centers the cell contents horizontally within the cell. 

    The Align Right button         aligns the cell contents with the right edge of the cell. 

    The Top Align button        aligns the cell contents with the top edge of the cell. 

    The Middle Align button        centers the cell contents vertically within the cell. 

    The Bottom Align button        aligns the cell contents with the bottom edge of the cell. 

To align data: 

1.   Select the cell that contains the data you want to align. 

2.   On the Home tab, in the Alignment group, click the desired alignment button. 

4.4 Indenting Data 

Indenting moves data away from the edge of the cell. This is often used to indicate a level 

of less importance (such as a subtopic) (see Figure 41). 
 
 
 
 
 
 
 
 

 
Figure 41 – Indented Data 
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To indent data: 

1.   Select the cell that contains the data you want to indent. 

2.   On the Home tab, in the Alignment group, click the Increase Indent button       . Each 

click increments the amount of indentation by one character. 

NOTE: You can decrease the indentation of data by clicking the Decrease Indent button         

in the Alignment group on the Home tab of the Ribbon. 

4.5 Rotating Data 

You can rotate data clockwise, counterclockwise, or vertically within a cell. This is often 

used to label narrow columns or to add visual impact to a worksheet. 

To rotate data: 

1.   Select the cell that contains the data you want to rotate. 

2.   On the Home tab, in the Alignment group, click the Orientation button and select the 

desired option from the menu (see Figure 42). The row height automatically adjusts to fit 

the rotated data (see Figure 43). 

                                                                      Figure 43 – Rotated Data 

Figure 42 – Orientation Menu 

NOTE: You can restore the data to its default orientation by clicking the Orientation button 

and selecting the currently selected orientation. 

4.6 Wrapping Data 

Wrapping displays data on multiple lines within a cell. The number of wrapped lines 

depends on the width of the column and the length of the data. 

To wrap data: 

1.   Select the cell that contains the data you want to wrap. 

2.   On the Home tab, in the Alignment group, click the Wrap Text button       . The row 

height automatically adjusts to fit the wrapped data  

(see Figure 44). 

NOTE: You can restore the data to its original format  

by clicking the Wrap Text button again. 

 

 
          Figure 44 – Wrapped Data 
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4.7 Merging Cells 

Merging combines two or more adjacent cells into one larger cell. This is a great way to 

create labels that span several columns. 

NOTE: If the cells you intend to merge have data in more than one cell, only the data in the 

upper-left cell remains after you merge the cells. 

To merge cells: 

1.   Select the cells that you want to merge. 

2.   On the Home tab, in the Alignment group, click the Merge & Center button to merge 

the selected cells into one cell and center the data, or click the Merge & Center arrow and 

select one of the following options (see Figure 45): 

 Merge Across: Merges each row of the selected cells into a larger cell. 

 Merge Cells: Merges the selected cells into one cell. 
 

 
Figure 45 – Merge & Center Menu 

 

NOTE: You can split a merged cell by clicking the Merge & Center arrow, and then 

clicking Unmerge Cells on the menu. 

4.8 Copying Cell Formatting 

You can copy the formatting of a specific cell and apply it to other cells in the worksheet. 

This can save you time and effort when multiple formats have been applied to a cell and 

you want to format additional cells with all the same formats. 

To copy cell formatting: 

1.   Select the cell that has the formatting you want to copy. 

2.   On the Home tab, in the Clipboard group, click the Format Painter button       . The 

mouse pointer changes to a plus sign with a paintbrush          . 

3.   Select the cell to which you want to apply the copied formatting. 

NOTE: If you want to apply the copied formatting to more than area, double-click the 

Format Painter button instead of single-clicking it. This keeps the Format Painter active 

until you press the Esc key. 

4.9 Applying Cell Styles 

A cell style is a set of formatting characteristics (such as font, font size, font color, cell 

borders and fill color) that you can use to quickly format the cells in a worksheet. In 

addition to saving you time, cell styles can help you keep formatting consistent throughout 

a worksheet. Excel 2013 includes several predefined styles that can be used to format 

headings, numbers, notes, etc. 
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To apply a cell style: 

1.   Select the cell to which you want to apply a style. 

2.   On the Home tab, in the Styles group, click the Cell Styles button and select the 

desired style from the gallery (see Figure 46). 

 
Figure 46 – Cell Styles Gallery 

4.10 Getting Help 
 

You can use the Excel Help system to get assistance on any topic or task. While some 

information is installed with Excel 2013 on your computer, most of the information resides 

online and is more up-to-date. You need an Internet connection to access resources from 

Office.com. 

To get help: 

1.   Click the Microsoft Excel Help button         on the right side of the Title bar. The 
Excel Help window opens, displaying general help topics (see Figure 47). 

 

 
4.11 Exiting Excel 
 
When you finish using Excel 2013, you should exit the program to free up system 
resources. 
To exit Excel 2013: 
 
1.   Click the Close button          in the upper-right corner of the program window. 
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CHAPTER-5 

Managing Worksheets 

At the bottom of each Excel workbook is an area for managing Excel worksheets. In the 

center of that area is a set of tabs for selecting worksheets. To the left of the worksheet 

tabs is a control for navigating through all the worksheets. To the right of the worksheet 

tabs is a control for adding a new worksheet. From this worksheet management area you 

can activate, add, delete, rename, move, or copy a worksheet. 

5.1 Activating a Worksheet 

To activate a worksheet 

 click on the tab for that worksheet at the bottom of the Excel workbook. If the worksheet 

tab is not available, you can scroll to the worksheet by using the navigation control to the 

left of all worksheet tabs. 

There are also two shortcuts that will allow you to jump to the next or previous worksheet: 

[Ctrl]+[Page Up] - Takes you to the next worksheet  

[Ctrl]+[Page Down] - Takes you to the previous worksheet 

5.2 Adding a New Worksheet 

To add a new worksheet, do any of the following: 

-- Click on the Insert Worksheet control, next to the worksheet tabs 

 

Figure 48 – Insert Worksheet  

-- Press [Shift]+[F11]  

-- Right click on any worksheet tab, click Insert, click on the General tab, then select the 

 

Figure 49 –Options to work with Worksheet   
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Figure 50 –insert Worksheet menu 

--Worksheet icon, and click the OK button 

5.3 Delete a Worksheet 

To delete a worksheet, do any of the following: 
-- Right click on the tab of the worksheet you want to delete then click Delete on the 

context menu  

-- Select the sheet you want to delete, then select Home | Cells and 
on the Delete dropdown selector choose Delete Sheet 

5.4 Rename a Worksheet 
To rename a worksheet, right click the tab of the worksheet you 
want to rename then click Rename on the context menu. Excel will 
highlight the worksheet name and you can type in the new name 
over it. 
5.5 Move a Worksheet 

To move a worksheet, just click the worksheet tab and drag it to 
where you want it. 

Figure 51 –Options to work with Worksheet   

You can also move a worksheet as follows: 

1. Right click on the worksheet tab to get the context menu  

2.  Select Move or copy 

3.  A Move or Copy dialog box will pop up. Do not select the Create a Copy checkbox 

at the bottom of the dialog box.  

4.  In the Before Sheet box, click the name of the worksheet you would like to move 

the sheet before. 
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5.6 Copy a Worksheet 

To copy a worksheet, just click the worksheet tab, then hold down the [Ctrl] key and drag it 

to where you want the copy. 

You can also copy a worksheet as follows: 

1.  Right click on the worksheet tab to get the context menu  

2.  Select Move or copy  

3.  A Move or Copy dialog box will pop up. Select the Create a Copy checkbox at the  

 bottom  of the dialog box.  

4.  In the Before Sheet box, click the name of the worksheet you would like the new  

           worksheet  to precede. 

5.7 Naming Cells and Ranges 

To make working with ranges easier, Excel allows you to name them. The name BookTitle, 
for example, is easier to remember than the range reference B6:B21. Named ranges can 
be used to navigate large worksheets. Named ranges can also be used in formulas 
instead of typing or pointing to specific cells. When you name a cell or range, Excel uses 
an absolute reference for the name by default, which is almost always what you want. You 
can see the absolute reference in the Refers to box in the New Name dialog box. There 
are two types of names you can create and use: defined name and table name. A defined 
name represents a cell, a range of cells, formula or constant, while a table name 
represents an Excel table, which is a collection of data stored in records (rows) and fields 
(columns). You can define a name for use in a worksheet or an entire workbook, also 
known as scope. To accommodate long names, you can resize the name box in the 

formula bar. The worksheet and formula bar work together to avoid overlapping content. 

5.7.1 Name a Cell or Range Using the Name Box 

1. Select the cell or range, or nonadjacent selections you want to name. 
2. Click the Name box on the formula bar. 
3. Type a name for the range.  

a. A range name can include up to 255 characters, uppercase or lowercase 
letters (not case sensitive), numbers, and punctuation, but no spaces or cell 
references. 

b. By default, names use absolute cell references. 
4. To adjust the width of the Name box, point between the Name box and the Formula 

box until the pointer changes to a horizontal double arrow, and then drag left or right.  
5. Press Enter. The range name will appear in the Name box whenever you select the 

range in the workbook. 

5.7.2 Let Excel Name a Cell or Range 

1. Select the cells, including the column or row header, you want to name. 
2. Click the Formulas tab. 
3. Click the Create from Selection button. 

4. Select the check box with the position of the labels in relation to the cells.  
i. Excel automatically tries to determine the position of the labels, so you might  
     not have to change any options. 

5. Click OK.  
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                          Figure 52 –Create names for selection  

5.7.3 Name a Cell or Range Using the New Name Dialog Box 

1. Select the cell or range, or nonadjacent selections you want to name. 
2. Click the Formulas tab. 
3. Click the Define Name button. 

4. Type a name for the reference. 
5. Click the Scope list arrow, and then click Workbook or a specific worksheet. 

6. If you want, type a description of the name.  
a. The current selection appears in the Refer to box. 

7. Click the Collapse Dialog button, select different cells and click the Expand Dialog 
button, or type = (equal sign) followed by a constant value or a formula. 

8. Click OK.  

5.7.4 How to Create a Named Range in Excel 

1. Drag select the cell or range of cells to be named, such as B2 to B5 

2. Click in the Name box, to the left of the formula bar 

3. Type a name for the list, e.g. Jan_sales 

4. Press the Enter key on the keyboard 

5. The name appears in the Name box 

Named Range Examples 

A named range can be used when creating charts, and in formulas and functions such as: 
 = SUM(Jan_sales ) 
= Jan_total + Feb_total + Mar_total 

http://spreadsheets.about.com/od/d/g/drag_select_def.htm
http://spreadsheets.about.com/od/c/g/cell_definition.htm
http://spreadsheets.about.com/od/r/g/range_def.htm
http://spreadsheets.about.com/od/glossary/g/name_box_def.htm
http://spreadsheets.about.com/od/f/g/Formula_bar_def.htm
http://spreadsheets.about.com/od/c/g/chart_def.htm
http://spreadsheets.about.com/od/f/g/formula_defined.htm
http://spreadsheets.about.com/od/f/g/function_def.htm
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CHAPTER-6 

6.1 Filter data in a range or table 

Using AutoFilter to filter data is a quick and easy way to find and work with a subset of 
data in a range of cells or table. Once you have filtered data in a range of cells or table, 
you can either reapply a filter to get up-to-date results, or clear a filter to redisplay all of the 
data. 

Filtered data displays only the rows that meet criteria that you specify and hides rows that 
you do not want displayed. After you filter data, you can copy, find, edit, format, chart, and 
print the subset of filtered data without rearranging or moving it. 

You can also filter by more than one column. Filters are additive, which means that each 
additional filter is based on the current filter and further reduces the subset of data.  

 Note   When you use the Find dialog box to search filtered data, only the data that is 
displayed is searched; data that is not displayed is not searched. To search all the data, 
clear all filters. 

The three types of filters 

Using AutoFilter, you can create three types of filters: by a list values, by a format, or by 
criteria. Each of these filter types is mutually exclusive for each range of cells or column 
table. For example, you can filter by cell color or by a list of numbers, but not by both; you 
can filter by icon or by a custom filter, but not by both.  

6.1.1 Reapplying a filter 

To determine if a filter is applied, note the icon in the column heading:  

 A drop-down arrow means that filtering is enabled but not applied. 

 Tip   When you hover over the heading of a column with filtering enabled but not applied, 
a screen tip displays "(Showing All)". 

 A Filter button means that a filter is applied.  

 Tip   When you hover over the heading of a filtered column, a screen tip displays the filter 
applied to that column, such as "Equals a red cell color" or "Larger than 150".  

When you reapply a filter, different results appear for the following reasons: 

 Data has been added, modified, or deleted to the range of cells or table column. 

 The filter is a dynamic date and time filter, such as Today, This Week, or Year to 
Date. 

 Values returned by a formula have changed and the worksheet has been 
recalculated. 

javascript:AppendPopup(this,'417084575_1')
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Do not mix storage formats 

For best results, do not mix storage formats, such as text and number or number and date, 
in the same column because only one type of filter command is available for each column. 
If there is a mix of storage formats, the command that is displayed is the storage format 
that occurs the most. For example, if the column contains three values stored as number 
and four as text, the filter command that is displayed is Text Filters.  

Filter text 

1. Do one of the following: 

Range of cells     

1. Select a range of cells containing alphanumeric data. 

2. On the Data tab, in the Sort & Filter group, click Filter. 

 

Figure 53 –Sort & Filter from Data menu 

Table     

1. Make sure that the active cell is in a table column that contains alphanumeric data. 

2. Click the arrow in the column header. 

3. Do one of the following: 

Select from a list of text values     

In the list of text values, select or clear one or more text values to filter by. 

The list of text values can be up to 10,000. If the list is large, clear (Select All) at the top, 
and then select the specific text values to filter by. 

 Tip   To make the AutoFilter menu wider or longer, click and drag the grip handle at the 

bottom. 

Create criteria     

1. Point to Text Filters and then click one of the comparison operator commands, or 
click Custom Filter.  

For example, to filter by text that begins with a specific character, select Begins With, or 
to filter by text that has specific characters anywhere in the text, select Contains. 

2. In the Custom AutoFilter dialog box, in the box on the right, enter text or select the 
text value from the list.  

javascript:AppendPopup(this,'263675744_2')
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For example, to filter by text that begins with the letter "J", enter J, or to filter by text that 
has "bell" anywhere in the text, enter bell. 

If you need to find text that shares some characters but not others, use a wildcard 
character.  

How to use wildcard characters 

The following wildcard characters can be used as comparison criteria for text filters. 

Use To find 

? (question mark) 
Any single character 

For example, sm?th finds "smith" and "smyth" 

* (asterisk) 
Any number of characters 

For example, *east finds "Northeast" and "Southeast" 

~ (tilde) followed by ?, *, or ~ 
A question mark, asterisk, or tilde 

For example, fy06~? finds "fy06?" 

3. Optionally, filter by one more criteria. 

How to add one more criteria 

1. Do one of the following: 

 To filter the table column or selection so that both criteria must be true, select 
And.  

 To filter the table column or selection so that either or both criteria can be 
true, select Or. 

2. In the second entry, select a comparison operator, and then in the box on the right, 
enter text or select a text value from the list. 

3.  To reapply a filter after you change the data, click a cell in the range or table, and 
then on the Data tab, in the Sort & Filter group, click Reapply. 

Filter numbers 
1. Do one of the following: 

Range of cells     
1. Select a range of cells containing numeric data. 

2. On the Data tab, in the Sort & Filter group, click Filter. 

 

Figure 54 –Sort & Filter from Data menu 
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Table     

1. Make sure that the active cell is in a table column that contains numeric data. 

2. Click the arrow in the column header. 
3. Do one of the following: 

Select from a list of numbers     

 In the list of numbers, select or clear one or more numbers to filter by. 

The list of numbers can be up to 10,000. If the list is large, clear (Select All) at the top, 

and then select the specific numbers to filter by. 

 Tip   To make the AutoFilter menu wider or longer, click and drag the grip handle at the 
bottom. 

Create criteria     

1. Point to Number Filters and then click one of the comparison operator commands 

or click Custom Filter.  

For example, to filter by a lower and upper number limit, select Between. 
2. In the Custom AutoFilter dialog box, in the box or boxes on the right, enter 

numbers or select numbers from the list.  
For example, to filter by a lower number of 25 and an upper number of 50, enter 25 and 
50. 

3. Optionally, filter by one more criteria. 

How to add one more criteria 

1. Do one of the following: 
 To filter the table column or selection so that both criteria must be true, select 

And.  

 To filter the table column or selection so that either or both criteria can be 
true, select Or. 

2. In the second entry, select a comparison operator, and then in the box on the right, 
enter a number or select a number from the list. 

4. To reapply a filter after you change the data, click a cell in the range or table, and 
then on the Data tab, in the Sort & Filter group, click Reapply. 

Filter dates or times 
1. Do one of the following: 

Range of cells     
1. Select a range of cells containing numeric data. 
2. On the Data tab, in the Sort & Filter group, click Filter. 

 

Figure 55 –Sort & Filter from Data menu 

Table     

1. Make sure that the active cell is in a table column that contains dates or times. 

2. Click the arrow in the column header. 
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3. Do one of the following: 

Select from a list of dates or times     

 In the list of dates or times, select or clear one or more dates or times to filter by. 

By default, all dates in the range of cells or table column are grouped by a hierarchy of 
years, months, and days. Selecting or clearing a higher level in the hierarchy selects or 
clears all nested dates below that level. For example, if you select 2006, months are listed 
below 2006, and days are listed below each month.  

The list of values can be up to 10,000. If the list of values is large, clear (Select All) at the 
top, and then select the values to filter by. 

 Tip   To make the AutoFilter menu wider or longer, click and drag the grip handle at the 

bottom. 

Create criteria     
1. Point to Date Filters and then do one of the following: 

Common filter     

 Note   A common filter is one based on a comparison operator. 

1. Click one of the comparison operator commands (Equals, Before, After, or 
Between) or click Custom Filter. 

2. In the Custom AutoFilter dialog box, in the box on the right, enter a date or time, 
select a date or time from the list, or click the Calendar button to find and enter a 

date.  
For example, to filter by a lower and upper date or time, select Between. 

3. In the Custom AutoFilter dialog box, in the box or boxes on the right, enter a date 
or time, select dates or times from the list, or click the Calendar button to find and 

enter a date.  

For example, to filter by an earlier date of "3/1/2006" and a later date of "6/1/2006", enter 
3/1/2006 and 6/1/2006. Or, to filter by an earlier time of "8:00 AM" and a later time of 
"12:00 PM", enter 8:00 AM and 12:00 PM. 

Dynamic filter     

 Note   A dynamic filter is one where the criteria can change when you reapply the filter.  

1. Click one of the pre-defined date commands.  
For example, to filter all dates by the current date, select Today, or by the following month, 
select Next Month. 

2. Click OK. 

 Notes  

 The commands under the All Dates in the Period menu, such as January or 
Quarter 2, filter by the period no matter what the year. This can be useful, for 

example, to compare sales by a period across several years.  

 This Year and Year to Date are different in the way that future dates are handled. 
This Year can return dates in the future for the current year, whereas Year to Date 

only returns dates up to and including the current date. 

Optionally, filter by one more criteria. 
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How to add one more criteria 

1. Do one of the following: 

 To filter the table column or selection so that both criteria must be true, select And. 

 To filter the table column or selection so that either or both criteria can be true, 
select Or. 

2. In the second entry, select a comparison operator, and then in the box on the right, 
enter a date or time, select a date or time from the list, or click the Calendar button 
to find and enter a date. 

4. To reapply a filter after you change the data, click a cell in the range or table, and 
then on the Data tab, in the Sort & Filter group, click Reapply. 

 Notes  

 All date filters are based on the Gregorian calendar.  

 Fiscal years and fiscal quarters always start in January of the calendar year. 

 If you want to filter by days of the week, format the cells to show the day of the 
week. If you want to filter by the day of the week regardless of the date, convert 
them to text by using the TEXT function. However, the TEXT function returns a text 
value, and so the filter command that is displayed would be Text Filters, not Date 
Filters. For more information, see Show dates as days of the week. 

 For the list of dates at the bottom of the AutoFilter menu in a date filter, you can 
change the hierarchical grouping of dates to a nonhierarchical list of dates. For 
example, you can filter for just two-digit years by manually selecting them from a 
nonhierarchical list. 

1. Click the Microsoft Office Button , click Excel Options, and then click the 
Advanced category. 

2. In the Display options for this workbook section, select a workbook, and then 
clear the Group dates in the AutoFilter menu check box. 

Filter for top or bottom numbers 

1. Do one of the following: 

Range of cells     

1. Select a range of cells containing numeric data. 

2. On the Data tab, in the Sort & Filter group, click Filter. 

Figure 56 –Sort & Filter from Data menu 
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Table     

1. Make sure that the active cell is in a table column that contains numeric data. 

2. Click the arrow in the column header. 

3. Point to Number Filters and then select Top 10. 

4. In the Top 10 AutoFilter dialog box, do the following. 

A. In the box on the left, click Top or Bottom. 

B. In the box in the middle, enter a number. 

C. In the box on the right, do one of the following: 

 To filter by number, click Items. 

 To filter by percentage, click Percent. 

5. To reapply a filter after you change the data, click a cell in the range or table, and 

then on the Data tab, in the Sort & Filter group, click Reapply. 

 Note   Top and bottom values are based on the original range of cells or table column and 

not the filtered subset of data. 

Filter for above or below average numbers 
1. Do one of the following: 

 
Range of cells     

1. Select a range of cells containing numeric data. 

2. On the Data tab, in the Sort & Filter group, click Filter. 

 

Figure 57 –Sort & Filter from Data menu 

Table     

1. Make sure that the active cell is in a table column that contains numeric data. 

2. Click the arrow in the column header. 

3. Point to Number Filters and then do one or more of the following: 

 To filter by numbers that are above the average, click Above Average. 
 To filter by numbers that are below the average, click Below Average. 

4. To reapply a filter after you change the data, click a cell in the range or table, and 
then on the Data tab, in the Sort & Filter group, click Reapply. 

 Note   Above and below average numbers are based on the original range of cells or 

table column and not the filtered subset of data. 
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Filter for blanks or nonblanks 

1. Do one of the following: 

Range of cells     

1. Select a range of cells. 
2. On the Data tab, in the Sort & Filter group, click Filter. 

 

Figure 58 –Sort & Filter from Data menu 

Table     

1. Make sure that the active cell is in a table column. 

2. Click the arrow in the column header. 

3. Do one of the following: 

 To filter for nonblanks, in the AutoFilter menu at the top of the list of values, 

select (Select All), and then at the bottom of the list of values, clear (Blanks). 

 To filter for blanks, in the AutoFilter menu at the top of the list of values, clear 

(Select All), and then at the bottom of the list of values, select (Blanks). 

 Note   The (Blanks) check box is available only if the range of cells or table column 

contains at least one blank cell. 

4. To reapply a filter after you change the data, click a cell in the range or table, and 

then on the Data tab, in the Sort & Filter group, click Reapply. 

Filter by cell color, font color, or icon set 

If you have manually or conditionally formatted a range of cells, by cell color or font color, 
you can also filter by these colors. You can also filter by an icon set created through a 
conditional format.  

1. Do one of the following: 

Range of cells     

1. Select a range of cells containing formatted by cell color, font color, or an icon set. 

2. On the Data tab, in the Sort & Filter group, click Filter. 

 

Figure 59 –Sort & Filter from Data menu 



Microsoft Excel    41 

 

Table     

1. Make sure that the table column contains data formatted by cell color, font color, or 

an icon set (No selection is required). 

2. Click the arrow in the column header. 

3. Select Filter by Color, and then depending on the type of format, select Filter by 

Cell Color, Filter by Font Color, or Filter by Cell Icon. 

4. Depending on the type of format, select a color, font color, or cell icon. 

5. To reapply a filter after you change the data, click a cell in the range or table, and 

then on the Data tab, in the Sort & Filter group, click Reapply. 

Filter by selection 

You can quickly filter data with criteria that is equal to the contents of the active cell. 

1. In a range of cells or table column, right click a cell containing the value, color, font 

color, or icon you want to filter by.  

2. Click Filter, and then do one of the following: 

 To filter by text, number, or date or time, click Filter by Selected 

Cell's Value. 

 To filter by cell color, click Filter by Selected Cell's Color. 

 To filter by font color, click Filter by Selected Cell's Font Color. 

 To filter by icon, click Filter by Selected Cell's Icon. 

3. To reapply a filter after you change the data, click a cell in the range or table, and 

then on the Data tab, in the Sort & Filter group, click Reapply. 

Clear a filter 

You can clear a filter for a specific column or clear all filters. 

Clear a filter for a column 

 To clear a filter for one column in a multicolumn range of cells or table, click the 

Filter button on the heading, and then click Clear Filter from <Column Name>. 

Clear all filters in a worksheet and redisplay all rows 

 On the Data tab, in the Sort & Filter group, click Clear. 

 

Figure 60 –Sort & Filter from Data menu 
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6.2 Sorting Data 

6.2.1 Sorting Data on single column 

You may find data in Excel 2010 worksheets easier to view if it's sorted on a particular 

column, in ascending or descending order. Excel sorts in the following pattern: numbers, 

spaces, special characters (such as !" # $ % & * < = >) and finally, alphabetic letters. 

Sorting data in ascending order sorts text from A to Z; numeric information from low to 
high; and dates with the earliest date first. Sorting data in descending order sorts text from 
Z to A; numeric information high to low; and dates with the most recent date first. 

 

Figure 61 –Data to Sort 

1 Create a contiguous list with headings specifying the contents of each 
column. 

For the easiest sorting, there should be no blank rows or columns in the list. 

1. In the column you want to sort by, click any cell containing data. 

If the data isn't in a contiguous list, you must first select the entire list. If Excel finds 
unselected data in columns next to the selected data, it may prompt you for more 
information. 

 

Figure 62 –Ascending /Descending button  

2. Click the Sort A to Z button in the Sort & Filter group on the Data tab. 
If the currentcell contains a value, the button's ScreenTip displays Sort Smallest to 
Largest. If the cell contains a date, the button's ScreenTip displays Sort Oldest to Newest. 
Excel sorts the entire list in ascending order on the specified column. 
3. Click the Sort Z to A button in the Sort & Filter group on the Data tab. 
Excel sorts the entire list by descending order on the current column. If Excel incorrectly 
sorts a cell that contains a value, make sure the cell is formatted as a number and not as 
text. 
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If your data doesn't sort as you expect, check to see if the data in the sort column contains 
any leading spaces and remove them. This occasionally happens when you import data 
from another file or application. 

 

How to Sort Excel 2010 Data on Multiple Columns 

If your Excel 2010 worksheet has become quite large, using the Sort dialogbox to sort on 
multiple columns can make it easier to find the data you need. The Sort dialog box lets you 
tell Excel what column to sort on next if two cells in the main sort column contain the same 
value or data. 

Although the most common sort is by rows, you can also sort by columns. In the Sort 
dialog box, click the Options button, choose Sort Left to Right, and click OK. 

4. Select or click in the list of data you want to sort. 

You can select only a single column of data if you want to sort that column independently 
of the rest of the data. However, in most cases you are likely to sort the entire list. 

 
Figure 63 – Sorting option for multiple columns  

5. Click the Sort button in the Sort & Filter group on the Data tab. 

The Sort dialog box appears. If your data includes column headings, make sure the My 
Data Has Headers option is checked. Excel usually detects the correct setting 
automatically. 

 

Figure 64 – Sorting option for multiple columns  

6. From the Sort By drop-down list, select the column by which you want to sort. 

This drop-down list includes the column headings for each column in the list. 

7. From the Sort On drop-down list, choose Values. 

Notice that you also can perform the sort on Cell Color, Font Color, or Cell Icon. Typically, 
you will perform a sort based on values (rather than formatting). 
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8. From the Order drop-down list, select how you want to sort the data. 

The options that appear in this list change based on the contents of the sort column. 
Choose A to Z or Z to A to sort text values, Smallest to Largest or Largest to Smallest to 
sort numeric data, or Oldest to Newest or Newest to Oldest to sort by dates. 

9. Click the Add Level button. 

Additional drop-down list boxes appear for the secondary sort column. This is the column 
Excel will sort by if two or more items are identical in the first Sort By option. 

 

Figure 65– Sorting option for multiple columns  

10. Repeat steps 3 through 5 for the new sorting level. 

After you specify the options for the secondary sort column, you can add more sort 
columns as needed. Use the Move Up and Move Down buttons if you decide to change 
the order of the sort columns. 

 

Figure 66 – Sorting option for multiple columns  

11. Click OK. 

The dialog box closes and Excel performs the sort process. 
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CHAPTER-7 

7.1 DATA TABLE   

 

7.1.1 How to Create a One-Variable Data Table  

To create a one-variable datatable to perform what-if analysis in Excel 2010, you enter a 
series of input values either across columns of a single row or down the rows of a single 
column. The formulas in a one-variable data table refer to only one input cell: a row input 
cell for input values entered across a row or a column input cell for input values entered 
down a column. 

The steps below for creating a one-variable data table follow a specific example (rather 
than using generic steps) to help you understand exactly how to use this feature in your 
worksheets. The following figure shows a Sales Projections worksheet for which a one-
variable data table is to be created. In this worksheet, the projected sales amount in cell 
B5 is calculated by adding last year's sales total in cell B2 to the amount that we expect it 
to grow in 2011 (calculated by multiplying last year's total in cell B2 by the growth 
percentage in cell B3). 

 
Figure 67 – Using Data table for One variable 

Sales projection worksheet with a column of possible growth percentages to be plugged 

into a one-variable data table. 

The column of possible growth rates ranging from 1% all the way to 5.5% is entered down 
column B in the range B8:B17. Follow these steps to create a one-variable data table that 
plugs each of these values into the sales growth formula: 

1. Copy the original formula entered in cell B5 into cell C7 by typing = (equal to) and 
then clicking cell B5. 
The copy of the original formula (into which the series of different growth rates in 
B8:B17 is to be substituted) is now the column heading for the one-variable data 
table. 

2. Select the cell range B7:C17. 
The range of the data table includes the formula along with the various growth 
rates. 

3. Choose What-If Analysis→Data Table in the Data Tools group on the Data tab. 
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Excel opens the Data Table dialogbox. 
4. Click in the Column Input Cell text box and then click cell B3, the Growth 2011 cell 

with the original percentage. 
Excel inserts the absolute celladdress, $B$3, into the Column Input Cell text box. 

5. Click OK. 

Excel creates the data table in the range C8:C17 by entering a formula using the 
TABLE function into this range. Each copy of this formula in the data table uses the 
growth rate percentage in the same row in column B to determine the possible 
outcome. 

 

Figure 68– Using Data table for One variable 

Sales projection worksheet after creating the one-variable data table in the range 

C8:C17. 

If you try to delete any single TABLE formula in the cell range C8:C17, Excel displays a 
Cannot Change Part of a Data Table alert dialog box — you must select the entire range 
of formulas (C8:C17 in this case) before you press Delete or click the Clear or Delete 
button on the Home tab. 
 
7.1.2 How to Create a Two-Variable Data Table in Excel 2010 

To create a two-variable datatable to perform what-if analysis in Excel 2010, you enter two 
ranges of possible input values for the same formula: a range of values for the Row Input 
Cell in the Data Table dialogbox across the first row of the table and a range of values for 
the Column Input Cell in the dialog box down the first column of the table. You then enter 
the formula (or a copy of it) in the cell located at the intersection of this row and column of 
input values. 

The steps below for creating a two-variable data table follow a specific example (rather 
than using generic steps) to help you understand exactly how to use this feature. The 
following figure shows a Sales Projections worksheet in which two variables are used in 
calculating the projected sales for the year 2011: a growth rate as a percentage of 
increase over last year's sales (in cell B3) and expenses calculated as a percentage of last 
year's sales (in cell B4). The formula in cell B5 is: =B2+(B2*B3)-(B2*B4). 
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Figure 69 – Using Data table for Two variables 

Sales projection worksheet with a series of possible growth and expense percentages to 
be plugged into a two-variable data table. 

The column of possible growth rates ranging from 1% to 5.5% is entered down column B 
in the range B8:B17, and a row of possible expenses percentages is entered in the range 
C7:F7. Follow these steps to complete the two-variable data table for this example: 

1. Copy the original formula entered in cell B5 into cell B7 by typing = (equal to) and 
then clicking cell B5. 
For a two-variable data table, the copy of the original formula must be entered at 
the intersection of the row and column input values. 

2. Select the cell range B7:F17. 
The range of the data table includes the formula along with the various growth 
rates. 

3. Choose What-If Analysis→Data Table in the Data Tools group on the Data tab. 
Excel opens the Data Table dialog box with the insertion point in the Row Input Cell 
text box. 

4. Click cell B4 to enter the absolute celladdress, $B$4, in the Row Input Cell text box. 
5. Click the Column Input Cell text box and then click cell B3 to enter the absolute cell 

address, $B$3, in this text box. 
6. Click OK. 

Excel fills the blank cells of the data table with a TABLE formula using B4 as the 
Row Input Cell and B3 as the Column Input Cell. 

http://www.dummies.com/how-to/content/how-to-create-a-twovariable-data-table-in-excel-21.html#glossary-group
http://www.dummies.com/how-to/content/how-to-create-a-twovariable-data-table-in-excel-21.html#glossary-tabs
http://www.dummies.com/how-to/content/how-to-create-a-twovariable-data-table-in-excel-21.html#glossary-cell_address
http://www.dummies.com/how-to/content/how-to-create-a-twovariable-data-table-in-excel-21.html#glossary-cell_address
http://www.dummies.com/how-to/content/how-to-create-a-twovariable-data-table-in-excel-21.html#glossary-cell_address


Microsoft Excel    48 

 

 
Figure 70 – Using Data table for Two variables 

 

Sales projection worksheet after creating the two-variable data table in the range C8:F17. 

The array formula {=TABLE(B4,B3)} that Excel creates for the two-variable data table in 
this example specifies both a Row Input Cell argument (B4) and a Column Input Cell 
argument (B3). Because this single array formula is entered into the entire data table 
range of C8:F17, keep in mind that any editing (in terms of moving or deleting) is restricted 
to the entire range. 

7.2 What Is A Pivot Table? 

The Pivot tables are used to summarize, analyze, explore and present your data. A Pivot 
table is a way to extract data from a long list of information and present it in a more 
meaningful and user friendly understandable format. For example, lets say that we have 
the data of student scores in a spreadsheet, you could turn this into a pivot table, and then 
view only the Math scores for each pupil. 

7.2.1 How To Create A Pivot Table In Excel 2010 

Here are the steps to create a Pivot table in Excel 2010. 

Step 1: First of all, please make sure to select the data range for which you want to make 
the pivot table. 

 
Figure 71 – Data for pivoting 
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Step 2: Insert the Pivot Table by going to the Insert tab and then clicking the Pivot Table 
icon. 

 

Figure 72 – Selecting Pivot table option 

Step 3: Select the target cells where you want to place the pivot table. For starters, select 
the New Worksheet option. 

 

Figure 73 – Creating  Pivot table  

Step 4:  The new worksheet will open and you will be able to see the pivot table that you 
just created, you can now generate the report from this table and can perform various 
operations on this table for better visualization and presentation of data. Just for example I 
calculated the sum of all of the selected cells. 

 
Figure 74– Using Pivot table  

In the right side, you will see the Pivot Table Panel which contains many useful options to 
work with the Pivot table. 
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Figure 75–Pivot table  Field list 

7.2.2 What’s New In The Excel 2010 Pivot Table 

As discussed in the introductory paragraph, Pivot Tables were also present in Microsoft 
Excel 2007, lets see what new enhancements have been made to the Excel 2010 Pivot 
tables. 

1. It includes a new feature calledShowValues As, right click the Pivot table and 
chooseShow Values As, you will see many new options here. It helps you in trying out 
several different calculations until you get exactly what you were looking for. 

 

     Figure 76–Pivot table options  

2. It offers many new calculations, almost six new calculations have been added to it. 

3. It includes some great visual totals. Visual Totals refer to what totals should be shown 
when one or more members are filtered. You can turn this feature ON of OFF, simply right 
click the Pivot Table and choose the Pivot Table Options option here. 



Microsoft Excel    51 

 

 

                      Figure 77–Pivot table options 

In the PivotTable Options window, go to the Tools & Filter tab and check/uncheck the 
Include filtered items in set totals optionto enable/disable it. 

 

Figure 78–Pivot table options 

The enhanced pivot table feature of Excel 2010 add feathers to this great product by 
Microsoft. You can read a more detailed post on the new features of Excel 2010 
7.3 How to Subtotal Data in Excel 2013 

You can use Excel’s Subtotals feature to subtotal data in a sorted list. To subtotal a data 
list, you first sort the list on the field for which you want the subtotals, and then you 
designate the field that contains the values you want summed — these don’t have to be 
the same fields in the data list. 
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When you use the Subtotals feature, you aren’t restricted to having the values in the 
designated field added together with the SUM function. You can instead have Excel return 
the number of entries with the COUNT function, the average of the entries with the 
AVERAGE function, the highest entry with the MAXIMUM function, the lowest entry with 
the MINIMUM function, or even the product of the entries with the PRODUCT function. 

To subtotal the salaries within each department in my example Employee Data list, first 
sort the list in A-to-Z order on the Dept column because Excel is to create a new subtotal 
at each change in the department entries within the list (Accounting, Administration, 
Engineering, and so on). 

Excel does not allow you to subtotal a data list formatted as a table. Before you can use 
the Subtotal command button, you must first convert your table into a normal range of 
cells. To do this, click a cell in the table and then click the Design tab on the Table Tools 
contextual tab on the Ribbon. 

Finally, click the Convert to Range command button in the Tools group followed by the Yes 
button in the alert dialog box asking you to confirm this action. Excel then removes the 
filter buttons from the columns at the top of the data list while still retaining the original 
table formatting. 

The following figure illustrates how easy it is to use the Subtotals feature to obtain totals in 
a data list. The sample Employee data list is sorted first by the Dept field in ascending 
order and then by the Salary field in descending order (Largest to Smallest) and converted 
the data list to a range. 

Then click the Subtotal command button on the Ribbon’s Data tab to open the Subtotal 
dialog box. 

 
Figure 77–Subtotal  options 

Here, the Dept field is selected as the field for which the subtotals are to be calculated in 
the At Each Change In drop-down list box, Sum as the function to use in the Use Function 
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drop-down list box, and the Salary check box as the field whose values are to be summed 
in the Add Subtotal To list box. 

The following figure shows the results obtained after clicking OK in the Subtotal dialog box. 
Here, you see the bottom of the data list showing the salary subtotals for the 
Administration, Engineering, Human Resources, and Information Services departments 
along with the grand total of the salaries for all the departments. 

The grand total is displayed at the bottom of the data list because the Summary below 
Data check box is selected in the Subtotal dialog box — if you didn't want a grand total, 
remove the check mark from this check box. 

 

Figure 78–Data with Subtotal 

As you can see, when you use the Subtotals command, Excel outlines the data at the 

same time that it adds the rows with the departmental salary totals and the grand total. 

This means that you can collapse the data list down to just its departmental subtotal rows 

or even just the grand total row simply by collapsing the outline down to the second or first 

level. 

(Remember that you can toggle between showing and hiding the outline symbols at the left 
edge of the data list by pressing Ctrl+8.) 
In a large data list, you may want Excel to insert page breaks (often referred to as breaks) 
every time data changes in the field on which the list is being subtotaled (that is, the field 
designated in the At Each Change In drop-down list box). 
To do this, you simply select the Page Break between Groups check box in the Subtotal 
dialog box to put a check mark in it before you click OK to subtotal the list. 
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CHAPTER-8 

8.1      Count and Sum Functions 

The most used functions in Excel are the functions that count and sum. You can count and 
sum based on onecriteria or multiple criteria. 
Count 
To count the number of cells that contain numbers, use the COUNT function. 

 

Countif 

To count cells based on one criteria (for example, higher than 9), use the following 
COUNTIF function. 

 

Countifs 

To count cells based on multiple criteria (for example, green and higher than 9), use the 
following COUNTIFS function. 

 



Microsoft Excel    55 

 

Sum 

To sum a range of cells, use the SUM function. 

 

Sumif 

To sum cells based on one criteria (for example, higher than 9), use the following SUMIF 
function (two arguments). 

 

To sum cells based on one criteria (for example, green), use the following SUMIF function 
(three arguments, last argument is the range to sum). 
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Sumifs 

To sum cells based on multiple criteria (for example, blue and green), use the following 
SUMIFS function (first argument is the range to sum). 

 

General note: in a similar way, you can use the AVERAGEIF and AVERAGEIFS function 
to average cells based on one or multiple criteria. 

8.2 Logical Functions 

The IF function checks whether a condition is met, and returns one value if TRUE and 
another value if FALSE. 

1. Select cell C2 and enter the following function. 

 

If Function 

The IF function checks whether a condition is met, and returns one value if TRUE and 
another value if FALSE. 

1. Select cell C2 and enter the following function. 

 

The IF function returns Correct because the value in cell A1 is higher than 10. 

And Function 

The AND Function returns TRUE if all conditions are true and returns FALSE if any of the 
conditions are false. 

Select cell D2 and enter the following formula. 
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The AND function returns FALSE because the value in cell B2 is not higher than 5. As a 
result the IF function returns Incorrect. 

Or Function 

The OR function returns TRUE if any of the conditions are TRUE and returns FALSE if all 
conditions are false. 

1. Select cell E2 and enter the following formula. 

 

The OR function returns TRUE because the value in cell A1 is higher than 10. As a result 
the IF function returns Correct. 

Note: the AND and OR function can check up to 255 conditions. 

 

8.3 Cell References 

Cell references in Excel are very important. Understand the difference between relative, 
absolute and mixed reference, and you are on your way to success. 

Relative Reference 

By default, Excel uses relative reference. See the formula in cell D2 below. Cell D2 
references (points to) cell B2 and cell C2. Both references are relative. 

 

1. Select cell D2, click on the lower right corner of cell D2 and drag it down to cell D5. 

http://www.excel-easy.com/introduction/range.html#fill-range
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Cell D3 references cell B3 and cell C3. Cell D4 references cell B4 and cell C4. Cell D5 
references cell B5 and cell C5. In other words: each cell references its two neighbors on 
the left. 

Absolute Reference 

See the formula in cell E3 below. 
1. To create an absolute reference to cell H3, place a $ symbol in front of the column letter 
and row number of cell H3 ($H$3) in the formula of cell E3. 

 

2. Now we can quickly drag this formula to the other cells. 

 

The reference to cell H3 is fixed (when we drag the formula down and across). As a result, 
the correct lengths and widths in inches are calculated. 

Mixed Reference 

Sometimes we need a combination of relative and absolute reference (mixed reference). 

1. See the formula in cell F2 below. 
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2. We want to copy this formula to the other cells quickly. Drag cell F2 across one cell, and 
look at the formula in cell G2. 

 

Do you see what happens? The reference to the price should be a fixed reference to 
column B. Solution: place a $ symbol in front of the column letter of cell B2 ($B2) in the 
formula of cell F2. In a similar way, when we drag cell F2 down, the reference to the 
reduction should be a fixed reference to row 6. Solution: place a $ symbol in front of the 
row number of cell B6 (B$6) in the formula of cell F2. 
Result: 

 

Note: we don't place a $ symbol in front of the row number of B2 (this way we allow the 
reference to change from B2 (Jeans) to B3 (Shirts) when we drag the formula down). In a 
similar way, we don't place a $ symbol in front of the column letter of B6 (this way we allow 
the reference to change from B6 (Jan) to C6 (Feb) and D6 (Mar) when we drag the 
formula across). 

3. Now we can quickly drag this formula to the other cells. 
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The references to column B and row 6 are fixed. 

 

8.4 Date & Time Functions 

To enter a date in Excel, use the "/" or "-" characters. To enter a time, use the ":" (colon). 
You can also enter a date and a time in one cell. 

 

Note: Dates are in US Format. Months first, Days second. This type of format depends on 
your windows regional settings.  

Year, Month, Day 

To get the year of a date, use the YEAR function. 

 

Note: use the MONTH and DAY function to get the month and day of a date. 

Date Function 

1. To add a number of days to a date, use the following simple formula. 

 
2. To add a number of years, months and/or days, use the DATE function. 
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Note: the DATE function accepts three arguments: year, month and day. Excel knows that 
6 + 2 = 8 = August has 31 days and rolls over to the next month (23 August + 9 days = 1 
September). 

Current Date & Time 

To get the current date and time, use the NOW function. 

 

Note: use the TODAY function to get the current date only. Use NOW()-TODAY() to get 
the current time only (and apply a Time format). 

Hour, Min, Sec 

To return the hour, use the HOUR function. 

 

Note: use the MINUTE and SECOND function to return the minute and second. 

Time Function 

To add a number of hours, minutes and/or seconds, use the TIME function. 

 

Note: Excel adds 2 hours, 10 + 1 = 11 minutes and 70 - 60 = 10 seconds. 
8.5 Text Functions 

 Excel has many functions to offer when it comes to manipulating text strings. 

Join Strings 

To join strings, use the & operator. 

http://www.excel-easy.com/examples/date-time-formats.html
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Note: to insert a space, use " " 

Left 

To extract the leftmost characters from a string, use the LEFT function. 

 

Right 

To extract the rightmost characters from a string, use the RIGHT function. 

 

Mid 

To extract a substring, starting in the middle of a string, use the MID function. 

 

Note: started at position 5 (p) with length 3. 

Len 

To get the length of a string, use the LEN function. 

 

Note: space (position 8) included! 

Find 

To find the position of a substring in a string, use the FIND function. 

 

Note: string "am" found at position 3. 
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CHAPTER-9 

Excel Charts 

In Excel, you can create charts. A chart is a graphical representation of numbers. 

9.1 Creating Charts 

In Microsoft Excel, you can represent numbers in a chart. On the Insert tab, you can 
choose from a variety of chart types, including column, line, pie, bar, area, and scatter. 
The basic procedure for creating a chart is the same no matter what type of chart you 
choose. As you change your data, your chart will automatically update. 
You select a chart type by choosing an option from the Insert tab's Chart group. After you 
choose a chart type, such as column, line, or bar, you choose a chart sub-type. For 
example, after you choose Column Chart, you can choose to have your chart represented 
as a two-dimensional chart, a three-dimensional chart, a cylinder chart, a cone chart, or a 
pyramid chart. There are further sub-types within each of these categories. As you roll 
your mouse pointer over each option, Excel supplies a brief description of each chart sub-
type. 

Create a Chart 

 

 To create the column chart shown above, start by creating the worksheet below exactly as 

shown. 

 

After you have created the worksheet, you are ready to create your chart. 
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9.2 Create a Column Chart 

.  

1. Select cells A3 to D6. You must select all the cells containing the data you want in  

 your chart. You should also include the data labels. 

2. Choose the Insert tab. 

3. Click the Column button in the Charts group. A list of column chart sub-types types  

 appears. 

4. Click the Clustered Column chart sub-type. Excel creates a Clustered Column chart 

and the Chart Tools context tabs appear. 

9.3 Apply a Chart Layout 

Context tabs are tabs that only appear when you need them. Called Chart Tools, there are 

three chart context tabs: Design, Layout, and Format. The tabs become available when 

you create a new chart or when you click on a chart. You can use these tabs to customize 

your chart. 

You can determine what your chart displays by choosing a layout. For example, the layout 

you choose determines whether your chart displays a title, where the title displays, 

whether your chart has a legend, where the legend displays, whether the chart has axis 

labels and so on. Excel provides several layouts from which you can choose. 
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Apply a Chart Layout 

 

1. Click your chart. The Chart Tools become available. 

2. Choose the Design tab. 

3. Click the Quick Layout button in the Chart Layout group. A list of chart layouts  

 appears. 

4. Click Layout 5. Excel applies the layout to your chart. 

9.4 Add Labels 

When you apply a layout, Excel may create areas where you can insert labels. You use 

labels to give your chart a title or to label your axes. When you applied layout 5, Excel 

created label areas for a title and for the vertical axis. 

Add labels 

 

Before 

 

 

After 



Microsoft Excel    66 

 

1. Select Chart Title. Click on Chart Title and then place your cursor before the C in  

     Chart and hold down the Shift key while you use the right arrow key to highlight the  

     words Chart Title. 

2. Type Toy Sales. Excel adds your title. 

3. Select Axis Title. Click on Axis Title. Place your cursor before the A in Axis. Hold  

     down the Shift key while you use the right arrow key to highlight the words Axis  

     Title. 

4. Type Sales. Excel labels the axis. 

5. Click anywhere on the chart to end your entry. 

9.5 Switch Data 

If you want to change what displays in your chart, you can switch from row data to column 

data and vice versa. 

Switch Data 

 

Before 

 

After 

1. Click your chart. The Chart Tools become available. 

2. Choose the Design tab. 

3. Click the Switch Row/Column button in the Data group. Excel changes the data in  

  your chart. 

9.6 Change the Style of a Chart 

A style is a set of formatting options. You can use a style to change the color and format of 

your chart. Excel 2007 has several predefined styles that you can use. They are numbered 

from left to right, starting with 1, which is located in the upper-left corner. 
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Change the Style of a Chart 

 

1. Click your chart. The Chart Tools become available. 

2. Choose the Design tab. 

3. Click the More button  in the Chart Styles group. The chart styles appear. 

 

4. Click Style 42. Excel applies the style to your chart. 

9.7 Change the Size and Position of a Chart 

When you click a chart, handles appear on the right and left sides, the top and bottom, and the 

corners of the chart. You can drag the handles on the top and bottom of the chart to increase 

or decrease the height of the chart. You can drag the handles on the left and right sides to 

increase or decrease the width of the chart. You can drag the handles on the corners to 
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increase or decrease the size of the chart proportionally. You can change the position of a 

chart by clicking on an unused area of the chart and dragging. 

Change the Size and Position of a Chart 

 

 

1. Use the handles to adjust the size of your chart. 

2. Click an unused portion of the chart and drag to position the chart beside the data. 

9.8 Move a Chart to a Chart Sheet 

By default, when you create a chart, Excel embeds the chart in the active worksheet. 

However, you can move a chart to another worksheet or to a chart sheet. A chart sheet is a 

sheet dedicated to a particular chart. By default Excel names each chart sheet sequentially, 

starting with Chart1. You can change the name. 

Move a Chart to a Chart Sheet 
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1. Click your chart. The Chart Tools become available. 

2. Choose the Design tab. 

3. Click the Move Chart button in the Location group. The Move Chart dialog box  

           appears. 

 

4. Click the New Sheet radio button. 

5. Type Toy Sales to name the chart sheet. Excel creates a chart sheet named Toy Sales 

and places your chart on it. 

9.9 Change the Chart Type 
Any change you can make to a chart that is embedded in a worksheet, you can also make to a 
chart sheet. For example, you can change the chart type from a column chart to a bar chart. 
Change the Chart Type 

1. Click your chart. The Chart Tools become available. 
2. Choose the Design tab. 
3. Click Change Chart Type in the Type group. The Chart Type dialog box appears. 
4. Click Bar. 
5. Click Clustered Horizontal Cylinder. 
6. Click OK. Excel changes your chart type. 

7.      

 



Microsoft Excel    70 

 

CHAPTER-10 

Introduction 

Many of the commands you'll use to prepare your workbook for printing and PDF export can 

be found on the Page Layout tab. These commands let you control the way your content will 

appear on a printed page, including the page orientation and margin size. Other page layout 

options, such as print titles and page breaks, can help make your workbook easier to read. 

10.1 Page Layout view 

Before you start modifying a workbook's page layout, you may want to view the workbook 

in Page Layout view, which can help you visualize your changes. 

To access Page Layout view, locate and select the Page Layout view command in the 

bottom-right corner of your workbook. 

 

10.2 Page orientation 

Excel offers two page orientation options: landscape and portrait. Landscape orients the 

page horizontally, while portrait orients the page vertically. Portrait is especially helpful for 

worksheets with a lot of rows, while landscape is best for worksheets with a lot of columns. In 

the example below, portrait orientation works best because the worksheet includes more rows 

than columns. 

 



Microsoft Excel    71 

 

To change page orientation: 

1. Click the Page Layout tab on the Ribbon. 

2. Select the Orientation command, then choose 

either Portrait or Landscape from the drop-down menu. 

 

3. The page orientation of the workbook will be changed. 

10.3 Page margins 

10.3.1 To format page margins: 

A margin is the space between your content and the edge of the page. By default, 

every workbook's margins are set to Normal, which is a one-inch space between the 

content and each edge of the page. Sometimes you may need toadjust the margins to 

make your data fit more comfortably on the page. Excel includes a variety of predefined 

margin sizes. 

1. Click the Page Layout tab on the Ribbon, then select the Margins command. 

2. Select the desired margin size from the drop-down menu. In our example, we'll 

select Narrow to fit more of our content on the page. 

3. The margins will be changed to the selected size. 

10.3.2 To use custom margins: 

Excel also allows you to customize the size of your margins in the Page  Setup dialog box. 

1. From the Page Layout tab, click Margins. Select Custom Margins... from the drop-

down menu. 
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10.4  Print Titles 

To include Print Titles: 

If your worksheet uses title headings, it's important to include these headings on each page 

of your printed worksheet. It would be difficult to read a printed workbook if the title headings 

appeared only on the first page. ThePrint Titles command allows you to select specific rows 

and columns to appear on each page. 

1. Click the Page Layout tab on the Ribbon, then select the Print Titles command. 

 

2. The Page Setup dialog box will appear. From here, you can 

choose rows or columns to repeat on each page. In our example, we'll repeat a 

row. 

3. Click the Collapse Dialog button next to the Rows to repeat at top: field. 
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4. The cursor will become a small selection arrow  and the Page Setup dialog 

box will be collapsed. Select the row(s) you want to repeat at the top of each 

printed page. In our example, we'll select row 1. 

 

5. Row 1 will be added to the Rows to repeat at top: field. Click the Collapse 

Dialog button again. 

 

6. The Page Setup dialog box will expand. Click OK. Row 1 will be printed at the top of 

every page. 
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10.5 Page Break 

To insert a page break: 

If you need to print different parts of your workbook across separate pages, you can 

insert a page break. There are two types of page breaks: vertical and horizontal. 

Vertical page breaks separate columns, while horizontal page breaks separate rows. In 

our example, we'll insert a horizontal page break. 

1. Locate and select the Page Break view command. The worksheet will appear 

in Page Break view. 

 

2. Select the row below where you want the page break to appear. For example, if 

you want to insert a page break between rows 28 and 29, select row 29. 
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3. Click the Page Layout tab on the Ribbon, select the Breaks command, then 

click Insert Page Break. 

 

4. The page break will be inserted, represented by a dark blue line. 
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When viewing your workbook in Normal view, inserted page breaks are represented by 

a solid gray line, while automatic page breaks are represented by a dashed line. 

 

 

 

1. The Page Setup dialog box will appear. 

2. Adjust the values for each margin, then click OK. 



Microsoft Excel    77 

 

 

3. The margins of the workbook will be changed. 

10.6 Inserting Header and Footer 

To insert headers and footers: 

You can make your workbook easier to read and look more professional by 

including headers and footers. Theheader is a section of the workbook that appears in 

the top margin, while the footer appears in the bottom margin. Headers and footers 

generally contain information such as page number, date, and workbook name. 

1. Locate and select the Page Layout view command at the bottom of the Excel 

window. The worksheet will appear in Page Layout view. 

 

2. Select the header or footer you want to modify. In our example, we'll modify 

the footer at the bottom of the page. 
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3. The Header & Footer Tools tab will appear on the Ribbon. From here, you can 

access commands that will automatically include page numbers, dates, and 

workbook names. In our example, we'll add page numbers. 

 

4. The footer will change to include page numbers automatically. 
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10.7 How to Print in Excel 2013 

To save paper and your sanity, print your worksheet directly from the Print screen in Excel 
2013’s Backstage view by clicking File→Print (or simply pressing Ctrl+P or Ctrl+F2). The Print 

screen shows you at-a-glance your current print settings along with a preview of the first page 
of the printout. 

You can also add a Print Preview and Print command button to the Quick Access toolbar that 
opens this Print screen in the Backstage view. Click the Customize Quick Access Toolbar 
button followed by the Print Preview and Print option on its drop-down menu to add this button 
at the end of the toolbar. Click this button anytime you want to preview a report before sending 
it to your printer. 
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You can use the Print Preview feature in the Print screen before you print any worksheet, 
section of worksheet, or entire workbook. Because of the peculiarities in paging worksheet 
data, you often need to check the page breaks for any report that requires more than one 
page. 

The print preview area in the Print panel shows you exactly how the worksheet data will page 
when printed. If necessary, you can return to the worksheet where you can make changes to 
the page settings from the Page Layout tab on the Ribbon before sending the report to the 
printer when everything looks okay. 

When Excel displays a full page in the print preview area, you can barely read its contents. To 
increase the view to actual size to verify some of the data, click the Zoom to Page button in 
the lower-right corner of the Print panel. You can see what the first page of the four-page 
report looks like after zooming in by clicking this Zoom to Page button. 

 

After you enlarge a page to actual size, use the scroll bars to bring new parts of the page into 
view in the print preview area. To return to the full-page view, click the Zoom to Page button a 
second time to deselect it. 

Excel indicates the number of pages in a report at the bottom of the print preview area. If your 
report has more than one page, you can view pages that follow by clicking the Next Page 
button to the right of the final page number. To review a page you’ve already seen, back up a 
page by clicking the Previous Page button to the left of the first page number. 

To display markers indicating the current left, right, top and bottom margins along with the 
column widths, click the Show Margins button to the immediate left of the Zoom to Page 
button. You can then modify the column widths as well as the page margins by dragging the 
appropriate marker. 
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When you finish previewing the report, the Print screen offers you the following options for 

changing certain print settings before you send it to the printer: 

 Print button with the Number of Copies combo box: Use this button to print the 

spreadsheet report using the current print settings listed on the panel. Use the combo box 

to indicate the number of copies you want when you need multiple copies printed. 

 Printer drop-down button: Use this button to select a new printer or fax to send the 

spreadsheet report to when more than one device is installed. (Excel automatically 

displays the name of the printer that’s installed as the default printer in Windows.) 

 Settings drop-down buttons: These include a Print What drop-down button with 

attendant Pages combo boxes: Use the Print What drop-down button to choose between 

printing only the active worksheets in the workbook, the entire workbook, the current cell 

selection in the current worksheet, and the currently selected table in the current 

worksheet. Use the combo boxes to restrict what’s printed. 

Beneath the combo boxes, you find drop-down list buttons to print on both sides of each 

page in the report, collate the pages of the report, and switch the page orientation from 

Portrait to Landscape. Additionally, you can select a paper size based on your printer’s 

capabilities other than the default 8.5″ x 11″ letter, and customize the size of the report’s 

margins. 

 


